Jump to content

.London Domains - £4
Photo

a:active only working on home page (index.php)

mobile site a:active button android

  • Please log in to reply
No replies to this topic

#1 beelzebomb

beelzebomb
  • Member
  • Newbie
  • 4 posts

Posted 22 May 2013 - 10:37

Ok this is driving me mad.
 
 
This is a mobile specific website, the standard orange Android on-click state is disabled with:
 
* { -webkit-tap-highlight-color: rgba(0,0,0,0); }
 

 

The CSS for the buttons is:

 

.buttons {position: relative; margin: 0 auto 0 auto; height: 55px; font-size: 18px; width: auto; border-bottom: 1px solid #ece8db; text-align: left; padding: 0; }        
a.fill {display:block; height:100%; width:100%; height: 35px; padding: 20px 0 0 5px; text-decoration: none; }    
.buttimg { margin: -5px 20px 0 0; }       
.buttons a:active { background: #1367c7;  }
 

 

The HTML for the buttons is:
 
<div class="buttons">
  <a href="tel:01279xxxxx" class="fill"> <span>Call Us</span> <img src="images/arrow.png" width="20px" class="buttimg" align="right" alt=""/> </a>
</div>
 
 
The a:active state is working perfectly on the home page (index.php) but is not working on any of the other pages, yet the button code is the same for each page! The "webkit-tap-highlight-color" disabling of the default on-click/tap colour is working on all pages. 
 
Is this just another ridiculous Android bug or is there something I'm missing?

Edited by beelzebomb, 22 May 2013 - 10:39.

  • 0





Also tagged with one or more of these keywords: mobile site, a:active, button, android

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users